July 28, 2022 AWS us-east-2 Issues
Incident Report for Panther Labs
Resolved
Our monitoring indicates that there is no further impact from this issue on Panther customer deployments. Additionally, AWS has updated their status page to indicate that they have made progress recovering the resources impacted by this outage. We will continue to follow this issue and provide updates if we observe additional service disruptions.

We may reach out to individual customers if we identify ongoing issues as a result of this downtime.
Posted Jul 28, 2022 - 13:22 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2022 - 12:45 PDT
Identified
Panther has confirmed an AWS outage in the us-east-2 region (https://health.aws.amazon.com/health/status) that began at 17:11 UTC. This outage is affecting multiple AWS services including Lambda and DynamoDB. Customers with Panther deployments in us-east-2 may experience page load errors and service latency while these systems recover. Other customer resources in us-east-2 may also experience issues.

We will continue to update this incident as more information becomes available.
Posted Jul 28, 2022 - 11:05 PDT
This incident affected: Panther Console (Web App), Data Ingestion into Panther (Log Processing), Detections (Rules and Policies), Investigation, Data Retention, and Search (Data Lake), and Alert Delivery.