September 20, 2022 GitHub API Gateway Errors
Incident Report for Panther Labs
Resolved
GitHub has updated their incident (https://www.githubstatus.com/incidents/v5bcd4pzckky) to indicate that the audit log API is now functioning as intended. Our monitoring indicates that all customer accounts with GitHub log pullers are fully operational. Data that was delayed as a result of this incident has already been successfully backfilled for all customers.
Posted Sep 20, 2022 - 07:55 PDT
Identified
GitHub has opened an incident (https://www.githubstatus.com/incidents/v5bcd4pzckky) reporting that their audit log REST API requests are currently disabled and they are working on a fix. This is the root cause of the Panther GitHub log puller errors.

We will update this incident when more information is available.
Posted Sep 20, 2022 - 05:33 PDT
Investigating
Panther has identified an issue with the GitHub Audit Log puller that started at 2:03 am UTC. The GitHub endpoint is returning a 502 Gateway Error for all requests. This is impacting data ingestion for all customers using the GitHub Audit Log Puller.

Panther’s team is currently investigating the root cause of this problem with GitHub and we will update this incident as our investigation and remediation process progresses.
Posted Sep 19, 2022 - 23:52 PDT
This incident affected: Data Ingestion into Panther (Log Processing).