Snowflake Outage

Incident Report for Panther Labs

Update

Snowflake has confirmed that the underlying incident has been resolved and services have returned to normal. At this time, we expect Panther services to be operating normally as well.

If you continue to experience any unexpected behavior or issues, please let us know by contacting our support team.

Thank you for your patience while we monitored this incident.
Posted Aug 03, 2026 - 13:18 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2026 - 13:14 PDT

Investigating

Snowflake is currently experiencing an outage affecting some of their infrastructure (https://status.snowflake.com/incidents/xfv4kdj30rcb). As a result, some Panther customers may experience query timeouts or slower performance on their instances. Real-time detection and alerting should be unaffected.

We're actively monitoring the situation. We'll update this page as soon as we have more information.

Thanks for your patience.
Posted Aug 03, 2026 - 08:20 PDT
This incident affects: Investigation, Data Retention, and Search (Data Lake).