IPinfo enrichment update failures
Incident Report for Panther Labs
Resolved
IPinfo has pushed a fix to resolve the problem, and we have confirmed that there are no more issues with our IPinfo Privacy data lake enrichment.

We will continue to monitor but expect no further issues.
Posted Aug 29, 2023 - 17:01 PDT
Identified
After investigation, Panther has identified that IPinfo is sending over improperly formatted data, causing problems with our IPinfo Privacy data lake enrichment. We have engaged with IPinfo and will provide an update as soon as more information is available.
Posted Aug 29, 2023 - 09:12 PDT
Investigating
Panther has identified an issue with our IPinfo Privacy data lake enrichment that is preventing the table from being updated with the latest data. Our engineering team is actively investigating the issue, and we will post an update shortly.

Customers utilizing IPinfo enrichment may encounter a “lookup update failed for ipinfo_privacy_datalake” system error as a result of this issue.

Apart from the failure to update, IPinfo tables are functioning as expected at this time. Other core Panther functionalities, including the detection engine and log ingestion, are unaffected.
Posted Aug 29, 2023 - 07:01 PDT
This incident affected: Investigation, Data Retention, and Search (Data Lake).