Snowflake has confirmed that the issue has been resolved and service has been restored. We’ve confirmed that Panther services are operating normally and will continue to monitor the environment.
Posted Sep 04, 2026 - 05:46 PDT
Monitoring
Snowflake has implemented a fix and service has been restored. (https://status.snowflake.com/incidents/fl9tkpj8d7hk) We’re continuing to monitor the environment to ensure all services are functioning normally.
Thanks for your patience.
Posted Sep 04, 2026 - 02:57 PDT
Investigating
Snowflake is currently experiencing an outage affecting some parts of their infrastructure (https://status.snowflake.com/incidents/fl9tkpj8d7hk). As a result, some Panther customers may experience query timeouts or slower performance on their instances. Real-time detection, alerting and ingestion should be unaffected.
We're actively monitoring the situation. We'll update this page as soon as we have more information.
Thanks for your patience.
Posted Sep 04, 2026 - 01:24 PDT
This incident affected: Investigation, Data Retention, and Search (Data Lake).